Speedtouch 330 USB driver problems

Well, for once, a problem of my own to report. I’m having some issues with the Speedtouch USB drivers. I installed a USB device that caused my system to go absolutely haywire. When I uninstalled it, a bunch of other devices went a bit nuts as well. Tried to reinstall the Speedtouch and now Windows XP keeps redetecting the device. I’ve narrowed it down, it’s definitely an issue with the drivers themselves on the system, but can’t seem to fix it. I’m updating this from my laptop right now (useful information, the Speedtouch drivers install fine in Vista Home Premium!)

Thankfully I’m not the only one with this issue. So, I’ll let you guys know how to fix it and if what The Scream forum people suggest works.

Also, thanks to SFC for the link (acronym to protect the delicate sensibilities!) It’s a funny blog, full of rage.

Edit: The Scream walk through works. Beware though, the French download from CCCleaner doesn’t actually work. Australian does.

Advertisements

6 responses to “Speedtouch 330 USB driver problems

  1. Hurry up & fix it – I have the same problem!

  2. I bought a Vista PC 3 weeks back. Using the Tiscali supplied Speedtouch 330 I could not connect to Tiscali brosadband. Over the past 18 days, thinking each modem might be faulty, I have purchased 3 further Speedtouch modems and discs and none have worked, plus I have spent ages talking to 5 different Tiscali technicians on the Tiscali premium rate helpline and no one at Tiscali has been able to attach any of my Speedtouch 330s to Tiscali via Vista. Actually one of the 330 modems sent to me by Tiscali is clearly labelled “for Vista! I suggest this total fiasco says a lot about Thomson Speedtouch 330 and Tiscali. Note that I would try sending a complaint to Thomson but their contact email for help and sales is never working! I wonder why!

  3. you need to install the beta driver for your speedtouch 330 you can get it here http://www.thomson-broadband.co.uk/codepages/content3.asp?c=7&ProductID=471

  4. This is for anyone using Vista!
    Goodluck! Happy surfing.
    ps.Can anyone let me now if this worked for them? cheers!

  5. well it seems Vista and XP sp 3 are cozing a hell lot of problems with SS330 … most of the time it a driver issue … Visat will not work with 4.0 but 4.1 drivers …..
    Well vista SP1 is another beast …. for later …

  6. Uh, just a quick note to steve gee (and others). Beware getting speedtouch drivers from the thompson-broadband website. At least, as with what I’ve discovered, the file UK_330_301_Win98-XP_driver.exe.zip
    has a virus – a trojan.agent-19301.
    (as shown in this screenshot http://www.tperry.plus.com/misc/screenshot.jpg)
    I managed to get a working, non-infected file from: http://drivers.softpedia.com/progDownload/Alcatel-SpeedTouch-330-3015-Download-10468.html
    Hope this helps someone!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s